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Lesson 1: Introduction



Interface
When you open Excel, the Excel Start Screen will appear. From here, you’ll be able to create 
a new workbook, choose a template, and access your recently edited workbooks.
• From the Excel Start Screen, locate and select Blank workbook to access the Excel 

interface.



The Tell me box works like a 
search bar to help you quickly 

find tools or commands you 
want to use.

Microsoft Account

From here, you can access 
your Microsoft account 

information, view your profile, 
and switch accounts.

Tell me
The Quick Access Toolbar lets you 
access common commands no 

matter which tab is selected. You 
can customize the commands 

depending on your preference.

Quick Access Toolbar 

The Ribbon

The Ribbon contains all of the 
commands you will need to perform 
common tasks in Excel. It has multiple 

tabs, each with several groups of 
commands.



Cell

Each rectangle in a workbook 
is called a cell. A cell is 

the intersection of a row and a 
column. Simply click to select a 

cell.

Column

A column is a group of cells 
that runs from the top of the 

page to the bottom. In Excel, 
column are identified by 

letters.

In the formula bar, you can 
enter or edit data, a formula, 
or a function that will appear 

in a specific cell.

Formula bar

The Name box displays 
location, or name, of a 

selected cell.

Name box

A row is a group of cells that 
runs from the left of the page 
to the right. In Excel, rows are 

identified by numbers.

Row



Excel files are called workbooks. 
Each workbook holds one or 

more worksheets. Click the tabs 
to switch between them, or right-

click for more options.

Worksheets

Worksheet View Options

There are three ways to view a 
worksheet. Simply click a 
command to select the 

desired view.

Zoom Control

Click and drag the slider to use 
the zoom control. The number 
to the right of the slider reflects 

the zoom percentage.



Using the menus
Microsoft Excel uses a tabbed Ribbon system. The Ribbon contains multiple tabs, each with 
several groups of commands. You will use these tabs to perform the most common tasks in 
Excel.

• Each tab will have one or more groups.

• Some groups will have an arrow you can click for more options.Students only



Using the menus
• Click each tab to see more commands.

• You can adjust how the Ribbon is displayed with the Ribbon Display Options.
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Versions

Excel 2003

Excel 2007

Excel 2010

Excel 2013

Excel 2016

Excel 2016
Included with Office 365
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Lesson 2: Data Entry



Formula Bar
In the formula bar, you can enter or edit data, a formula, or a function that will appear 
in a specific cell.

1. Open Excel application on your PC.
2. Select New, then click Blank workbook.
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Formula Bar
3. Click a cell to select it.

4. Type something into the selected cell, then press Enter on your keyboard. The content 
will appear in the cell and the formula bar. You can also input and edit cell content in 
the formula bar.
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By default, every row and column of a new workbook is set to same height and width. You 
can modify the column width and row height in different ways.

To modify column width:
1. Position the mouse over the column/row line in the column heading so the cursor 

becomes a double arrow.

Modifying Column & Row
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2. Click and drag the mouse to increase or decrease the column width.

3. Release the mouse. The column width will be changed.
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To modify row height:
1. Position the cursor over the row line so the cursor becomes a double arrow.

2. Click and drag the mouse to increase or decrease the row height.
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3. Release the mouse. The height of the selected row will be changed.
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To AutoFit column width:
The AutoFit feature will allow you to set a column's width to fit its content automatically.

2. Double-click the mouse. The column width will be changed automatically to fit the 
content.

1. Position the mouse over the column line in the column heading so the cursor becomes 
a double arrow.
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Wrapping text and merging cells

• Whenever you have too much cell content to be 
displayed in a single cell, you may decide to wrap the 
text or merge the cell rather than resize a column.
• Wrapping the text will automatically modify a cell's row 

height, allowing cell contents to be displayed on multiple 
lines.
• Merging allows you to combine a cell with adjacent 

empty cells to create one large cell.Students only



To wrap text in cells:
1. Select the cells you want to wrap. 
2. Click the Wrap Text command on the Home tab.
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3. The text in the selected cells will be wrapped.

Click the Wrap Text command again to unwrap the text.Students only



To merge cells using the Merge & Center command:
1. Select the cell range you want to merge.
2. Click the Merge & Center command on the Home tab.

3. The selected cells will be merged, and the text will be centered.
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Typography
To use the Bold, Italic, and Underline commands:

1. Select the cell(s) you want to modify.

2. Click the Bold (B), Italic (I), or Underline (U) command on the Home tab.Students only



3. The selected style will be applied to the text.

You can also press Ctrl+B on your keyboard to make selected text bold, Ctrl+I to apply italics, 
and Ctrl+U to apply an underline.
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To add a fill color:

1. Select the cell(s) you want to modify.

2. On the Home tab, click the drop-down arrow next to the Fill Color command, then select 
the fill color you want to use.
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3. The selected fill color will appear in the selected cells. We've also changed the font 
color to white to make it more readable with this dark fill color.
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Text alignment
• By default, any text entered into your worksheet will be aligned to the bottom-left of a cell, 

while any numbers will be aligned to the bottom-right. Changing the alignment of your cell 
content allows you to choose how the content is displayed in any cell.

Left Align: Aligns content to the left border of the cell

Center Align: Aligns content an equal distance from the left and right borders of the cell
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Right Align: Aligns content to the right border of the cell

Top Align: Aligns content to the top border of the cell

Middle Align: Aligns content an equal distance from the top and bottom borders of the cell
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Bottom Align: Aligns content to the bottom border of the cell

To change horizontal text alignment:
1. Select the cell(s) you want to modify.
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3. The text will realign.

2. Select one of the alignment commands on the Home tab.
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Format Cells / Data Formatting

• In Excel, you can format numbers in cells for things like 
currency, percentages, times, dates, and so on.
• This allows the spreadsheet to better understand your 

data, which can help ensure that your data remains 
consistent and that your formulas are calculated 
correctly.

If you don't need to use a specific number format, the spreadsheet will usually apply 
the general number format by default. However, the general format may apply some small 

formatting changes to your data.
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Applying number formats

1. Go to the Home tab, click the Number Format drop-down menu in the Number group, 
and select the desired format.

2. You can also click one of the quick number-formatting commands below the drop-down 
menu.
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Currency formats

If you applied the Currency number format, which adds currency symbols and displays two 
decimal places for any numerical values.

1. Go to the Home tab, click the Number Format drop-down menu in the Number group, 
and select Currency.

If currency displayed in US $ instead of MYR / RM, you need to change the Regional and 
Language setting in your PC control panel.
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Percentage formats

One of the most helpful number formats is the percentage (%) format. It displays values as 
percentages, such as 20% or 55%. This is especially helpful when calculating things like the 
cost of sales tax or a tip. When you type a percent sign (%) after a number, the percentage 
number format will be be applied to that cell automatically.

1. Go to the Home tab, click the Number Format drop-down menu in the Number group, 
and select Percentage.
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Date formats

Whenever you're working with dates, you'll want to use a date format to tell the spreadsheet 
that you're referring to specific calendar dates, such as July 15, 2014. Date formats also allow 
you to work with a powerful set of date functions that use time and date information to 
calculate an answer.

1. Go to the Home tab, click the Number Format drop-down menu in the Number group, 
and select Short Date/Long Date.

Short Date – 25/7/2018
Long Date – Wednesday, 25 July 2018

If you want to add the current date to 
a cell, you can use the Ctrl+; shortcut.Students only



Other date formatting options

1. To access other date formatting options, select the Number Format drop-down menu and 
choose More Number Formats. These are options to display the date differently, like 
including the day of the week or omitting the year.
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2. The Format Cells dialog box will appear. From here, you can choose the desired date 
formatting option.

3. As you can see in the formula bar, a custom date format doesn't change the actual date 
in our cell—it just changes the way it's displayed.Students only



Increase and Decrease Decimal
The Increase Decimal and Decrease Decimal commands allow you to control how many 
decimal places are displayed in a cell. These commands don't change the value of the cell; 
instead, they display the value to a set number of decimal places.

Decreasing the decimal will display the value rounded to that decimal place, but the actual 
value in the cell will still be displayed in the formula bar.Students only



Fill handle
If you're copying cell content to adjacent cells in the same row or column, the fill handle is a 
good alternative to the copy and paste commands.

1. Select the cell(s) containing the content you want to use, then hover the mouse over the 
lower-right corner of the cell so the fill handle appears.
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2. Click and drag the fill handle until all of the cells you want to fill are selected.

3. Release the mouse to fill the selected cells.
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To continue a series with the fill handle:

The fill handle can also be used to continue a series. Whenever the content of a row or 
column follows a sequential order, like numbers (1, 2, 3) or days (Monday, Tuesday, 
Wednesday), the fill handle can guess what should come next in the series.

1. Select the cell range that contains the series you want to continue.
2. Click and drag the fill handle to continue the series.
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3. Release the mouse. If Excel understood the series, it will be continued in the selected cells.

You can also double-click the fill handle instead of clicking and dragging. This can be useful 
with larger spreadsheets, where clicking and dragging may be awkward.
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Tables

Once you've entered information into your worksheet, you 
may want to format your data as a table. Excel includes 
several tools and predefined table styles, allowing you to 
create tables quickly and easily.
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Tables vs Border
There’s one common mistake most people did. Many people create table by adding border 
and fill colors to the cells. You should create your table by choosing Format as Table in the 
home tab. 

If you create table by choosing Format as Table, you can access to Table tab for more 
settings such as Table Name, Header Row, Filter Button, and more advanced features.
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To create a table:

1. Select the cells you want to format as a table.

2. From the Home tab, click the Format as Table command in the Styles group.
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3. Select a table style from the drop-down menu.
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4. A dialog box will appear, confirming the selected cell range for the table.
5. If your table has headers, check the box next to My table has headers, then click OK.
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6. The cell range will be formatted in the selected table style.
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To remove a table:

1. Select any cell in your table, then click the Design tab.
2. Click the Convert to Range command in the Tools group.

3. A dialog box will appear. Click Yes.
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4. The range will no longer be a table, but the cells will retain their data and formatting.
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5. To restart your formatting from scratch, click the Clear command on the Home tab. Next, 
choose Clear Formats from the menu.

Result:
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Lesson 3: Formatting



Adding and deleting rows and columns
Insert columns
1. Select the letter at the top of a column to select the column(s).

Excels inserts a new column to the left.

2. Click the Insert command on the Home tab.
Or, right-click the top of the column(s), and then select Insert.Students only



Adding and deleting rows and columns
Insert rows
1. Select the row number to select the row(s).

2. Click the Insert command on the Home tab.
Or, right-click the selected row(s), and then select Insert.Students only



Adding and deleting rows and columns
Delete rows or columns
1. Select the row(s) you want to delete.

2. Click the Delete command on the Home tab.
Or, right-click the selected row, and then select Delete.Students only



Hiding data
Hide or unhide columns in your spreadsheet to show just the data that you need to see or 
print.
1. Select one or more rows/columns, right-click the selected rows/columns, and then 

select Hide.
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Hiding data
2. The columns will be hidden. The green column line indicates the location of the hidden 

columns.
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Hiding data
3. To unhide the columns, select the columns on both sides of the hidden columns.
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Hiding data
4. The hidden columns will reappear.
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Copying, pasting, and moving
To copy and paste cell content:

Excel allows you to copy content that is already entered into your spreadsheet 
and paste that content to other cells, which can save you time and effort.

1. Select the cell(s) you want to copy.
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2. Click the Copy command on the Home tab, or press Ctrl+C on your keyboard.

3. Select the cell(s) where you want to paste the content. The copied cell(s) will have 
a dashed box around them.
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4. Click the Paste command on the Home tab, or press Ctrl+V on your keyboard.

5. The content will be pasted into the selected cells.
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To access more paste options:

You can also access additional paste options, which are especially convenient when 
working with cells that contain formulas or formatting. Just click the drop-down arrow on 
the Paste command to see these options.
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Instead of choosing commands from the Ribbon, you can access commands quickly 
by right-clicking. Simply select the cell(s) you want to format, then right-click the mouse. 
A drop-down menu will appear, where you'll find several commands that are also located on 
the Ribbon.
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To cut and paste cell content:

Unlike copying and pasting, which duplicates cell content, cutting allows you 
to move content between cells.

1. Select the cell(s) you want to cut. In our example, we'll select G5:G6.
2. Right-click the mouse and select the Cut command. Alternatively, you can use the 

command on the Home tab, or press Ctrl+X on your keyboard.
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3. Select the cells where you want to paste the content. The cut cells will now have 
a dashed box around them.

4. Right-click the mouse and select the Paste command. Alternatively, you can use the 
command on the Home tab, or press Ctrl+V on your keyboard.
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5. The cut content will be removed from the original cells and pasted into the selected cells.
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To move cell content:

Instead of cutting, copying, and pasting, you can drag and drop cells to move their 
contents.

1. Select the cell(s) you want to move.
2. Hover the mouse over the border of the selected cell(s) until the mouse changes to 

a pointer with four arrows.
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3. Click and drag the cells to the desired location.
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4. Release the mouse. The cells will be dropped in the selected location.
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Sorting Data

• As you add more content to a worksheet, organizing this 
information becomes especially important.
• You can quickly reorganize a worksheet by sorting your 

data.
• For example, you could organize a list of contact 

information by last name.
• Content can be sorted alphabetically, numerically, and in 

many other ways. Students only



Types of sorting

• When sorting data, it's important to first decide if you want 
the sort to apply to the entire worksheet or just a cell 
range.
• Sort sheet organizes all of the data in your worksheet by 

one column. Related information across each row is kept 
together when the sort is applied. 
• Sort range sorts the data in a range of cells, which can be 

helpful when working with a sheet that contains several 
tables. Sorting a range will not affect other content on the 
worksheet.
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To sort a sheet:

1. Select a cell in the column you want to sort by. In our example, we'll select cell C2.

2. Select the Data tab on the Ribbon, then click the A-Z command to sort A to Z, or the Z-A 
command to sort Z to A.
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3. The worksheet will be sorted by the selected column.
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To sort a range:

1. Select the cell range you want to sort.

2. Select the Data tab on the Ribbon, then click the Sort command.
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3. The Sort dialog box will appear. Choose the column you want to sort by.

4. Decide the sorting order (either ascending or descending).
5. Once you're satisfied with your selection, click OK.
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5. The cell range will be sorted by the selected column. Notice that the other content in the 
worksheet was not affected by the sort.

If your data isn't sorting properly, double-check your cell values to make sure they are 
entered into the worksheet correctly. Even a small typo could cause problems when sorting a 

large worksheet.Students only



Filtering Data

• If your worksheet contains a lot of content, it can be 
difficult to find information quickly.
• Filters can be used to narrow down the data in your 

worksheet, allowing you to view only the information you 
need.
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1. In order for filtering to work correctly, your worksheet should include a header row, which 
is used to identify the name of each column.

2. Select the Data tab, then click the Filter command. Students only



3. A drop-down arrow will appear in the header cell for each column.
4. Click the drop-down arrow for the column you want to filter.
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5. The Filter menu will appear.
6. Uncheck the box next to Select All to quickly deselect all data.
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7. Check the boxes next to the data you want to filter, then click OK.
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8. The data will be filtered, temporarily hiding any content that doesn't match the criteria.
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Conditional Formatting
• Conditional formatting provides another way to visualize data and make worksheets easier 

to understand.
• Conditional formatting allows you to automatically apply formatting—such as colors, icons, 

and data bars—to one or more cells based on the cell value. 
• To do this, you'll need to create a conditional formatting rule.
• For example, a conditional formatting rule might be: If the value is less than RM2000, color 

the cell red. By applying this rule, you'd be able to quickly see which cells contain values 
less than RM2000.
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To create a conditional formatting rule:

1. Select the desired cells for the conditional formatting rule.
2. On the Home tab, click Conditional Formatting command.
3. Hover the mouse over the desired conditional formatting type, then click Less Than.

2

3

1
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A dialog box will appear:
4. Enter the desired value(s).
5. Select a formatting style.
6. Click OK.

4 5

6
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7. The conditional formatting will be applied to the selected cells. 

8. If you change the value of cells which already applied conditional formatting, Excel will 
change the format of cell automatically.
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You can apply multiple conditional formatting rules to a cell range or worksheet, allowing 
you to visualize different trends and patterns in your data.
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Highlight values between
1. Select the desired cell ranges.
2. On the Home tab, in the Styles group, click Conditional Formatting.
3. Click Highlight Cells Rules > Between.

1

2

3
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4. Enter the desired lowest value and highest value.
5. Select a formatting style.
6. Click OK.

4 5

6
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Result: Excel highlight the value between in red color.
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Find Duplicates
You can find duplicates data/value easily by applying conditional formatting in Excel.

1. Select the desired cell ranges.
2. On the Home tab, in the Styles group, click Conditional Formatting
3. Click Highlight Cells Rules, Duplicate Values.

1

2

3
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4. Select a formatting style and click OK.

Result: Excel highlights the duplicate data.
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Top/Bottom Rules
To highlight the Top 10 Items:

1. Select the desired cells for the conditional formatting rule.

2. On the Home tab, in the Styles group, click Conditional Formatting.
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1. Hover the mouse over Top/Bottom Rules, then select Top 10 items.

2. Select a formatting style, and then click OK.Students only



Result: Excel calculate the top 10 items and formats the cells.

Students only



Conditional formatting presets
Excel has several predefined styles—or presets—you can use to quickly apply conditional 
formatting to your data. They are grouped into three categories:
• Data Bars are horizontal bars added to each cell, much like a bar graph.

• Icon Sets add a specific icon to each cell based on its value.

• Color Scales change the color of each cell based on its value. Each color scale uses a two-
or three-color gradient. For example, in the Green-Yellow-Red color scale, the highest values 
are green, the average values are yellow, and the lowest values are red.
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To use conditional formatting preset:

1. Select the desired cells for the conditional formatting rule.
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2. Click the Conditional Formatting command. A drop-down menu will appear.
3. Hover the mouse over the desired preset, then choose a preset style from the menu that 

appears.
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4. The conditional formatting will be applied to the selected cells.
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Remove conditional formatting
1. Click the Conditional Formatting command. A drop-down menu will appear.
2. Hover the mouse over Clear Rules, and choose which rules you want to clear.
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3. The conditional formatting will be removed.
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Manage Rules
Click Manage Rules to edit or delete individual rules. This is especially useful if you've 
applied multiple rules to a worksheet.

1. Click the Conditional Formatting command and choose Manage Rules.

2. Select to show formatting rules for current selection, worksheet or table.

3. Click New Rule, Edit Rule and Delete Rule to create, edit and delete rules. 
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Lesson 4: Inserts



Clipping Screens
You can quickly and easily add a screenshot to your Excel file to enhance readability or 
capture information without leaving the program that you are working in.

1. Click in the document at the location where you want to add the screenshot.
2. On the Insert tab, in the Illustrations group, click Screenshot.
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3. The Available Windows gallery appears, showing you all the windows that you currently 
have open. Do one of the following:

• To insert a screenshot of an entire window into your document, click the thumbnail image 
of that window.

• To add a selected portion of the first window shown in the Available Windows gallery, 
click Screen Clipping; when the screen turns white and the pointer becomes a cross, press 
and hold the left mouse button and drag to select the part of the screen that you want to 
capture.

Only one screenshot at a time can be added. To add multiple screenshots, repeat steps 2 
and 3 below.
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Inserting shapes, arrows, and other graphics
Add Shapes, Arrows
1. On the insert tab, click Shapes.
2. Select any shape you want to add.
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3. Click where you want the arrow to start, and drag to draw the shape.

You can change the look of your circle or curve by adding a shape fill or effect or changing 
the border.
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Add Graphic
1. Go to the Insert tab, click Picture. Insert Picture from your PC. 

2. Re-size the picture/image so that it can fit perfectly within the cell. You can also resize 
images by selecting it and dragging the edges
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1. Right-click on the picture and select Format Picture.

Lock the Picture with the Cell

If you want the image to stick to the cell, you need to lock the image to the cell to make sure 
it moves, filters, and hides with the cell.
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3. Now you can move cells, filter it, or hide it, and the picture will also move/filter/hide.

2. In the Format Picture pane, select Size & Properties and with the options in Properties, 
select ‘Move and size with cells’.
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Recommended Charts

• Excel has several different types of charts, allowing you to 
choose the one that best fits your data. In order to use 
charts effectively, you'll need to understand how different 
charts are used.
• If you're not sure which type of chart to use, 

the Recommended Charts command will suggest several 
different charts based on the source data.
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1. Select the cells you want to chart, including the column titles and row labels. These cells 
will be the source data for the chart. In our example, we'll select cells A1:F6.

2. From the Insert tab, click Recommended Charts.
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3. Select a chart on the Recommended Charts tab, to preview the chart.
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Linking Charts in PowerPoint
• You can insert and link a chart from an Excel workbook into your PowerPoint presentation. 

When you edit the data in the spreadsheet, the chart on the PowerPoint slide can be 
easily updated.
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1. Open the Excel workbook that 
has the chart that you want. 
Save the workbook.

2. Select the chart.
3. On the Home tab, in the 

Clipboard group, click Copy.

1

2

3
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5. Open the PowerPoint presentation that 
you want and select the slide that you 
want to insert the chart into.

6. On the Home tab, in 
the Clipboard group, click the arrow 
below Paste, and then do one of the 
following:

• If you want the chart to keep its look and 
appearance from the Excel file, 
select Keep Source Formatting & Link 
Data.

• If you want the chart to use the look and 
appearance of the PowerPoint 
presentation, select Use Destination 
Theme & Link Data.

5

6

If you were to subsequently move the Excel file to another folder, that would break the link 
between the chart in the PowerPoint presentation and the data in the Excel workbook.
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Update the data that's appearing in the chart

When the underlying Excel data has been changed in the workbook, you can make those 
changes be reflected in the chart that's appearing in your presentation:

1. Select the chart.
2. On the Chart Tools Design tab of the toolbar ribbon, in the Data group, select Refresh 

Data.

2
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Advanced Charts / Combo Charts

• An advanced chart is a chart that goes beyond the basic 
charts created by Excel.
• Let's say you have more than one set of data that you 

would like to compare on the same chart, you can create 
your basic chart with one set of data then add more 
datasets to it and apply other items.
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1. Select the cells you want to chart, including the column titles and row labels.

2. On the Insert tab, in the Charts group, click the Combo symbol.

3. Click Create Custom Combo Chart.

1

2

3
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The Insert Chart dialog box appears:
4. For the Rainy Days series, choose 

Clustered Column as the chart type.
5. For the Profit series, choose Line as the 

chart type.
6. Plot the Profit series on the secondary 

axis.
7. Click OK. 4

5 6

7
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Lesson 5: Formulas and Functions



Formula vs function

A function is a predefined formula that performs calculations using specific values in a 
particular order.

A formula is just like a calculator, Excel can add, subtract, multiply, and divide 
to calculate numerical information using formulas. 

Addition + Subtraction -

Multiplication * Division /

Exponents ^
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Examples of a Formula
When a user types an equals sign in a cell, they are starting to create a formula.
Examples of a formula include:
=4+3
=A3+C9
=B7+B8-(4*2)+1

Examples of a Function
When a user types an equals sign followed by a predefined set of letters (or clicks on the Fx
button in the formula bar), a function begins to be implemented.
=SUM(A3:A27)
=AVERAGE(F4:F8)
=NPV(0.12,A5:G5) Students only



Create formulas
1. Select a cell.

2. Type the equal sign =.

3. Select a cell or type its address in the selected cell.

Formulas in Excel always begin with the equal sign.
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4. Enter an operator. For example, - for subtraction.
5. Select the next cell, or type its address in the selected cell.

6. Press Enter. The result of the calculation appears in the cell with the formula.

Create formulas
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Functions
• In order to work correctly, a function must be written a specific way, which is 

called the syntax.
• The basic syntax for a function is the equals sign (=), the function name (SUM, for 

example), and one or more arguments.
• Arguments contain the information you want to calculate. The function in the 

example below would add the values of the cell range A1:A20.
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How to write functions

There’re three ways to write functions in Excel:
1. Enter a function manually
2. Insert a function from the Function Library
3. Insert FX
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To enter a function manually:
If you already know the function name, you can easily type it yourself.

1. Select the cell that will contain the function.
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2. Type the equals sign (=), and enter the desired function name. You can also select the 
desired function from the list of suggested functions that appears below the cell as you 
type.
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3. Enter or select the cell range for the argument inside parentheses.
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4. Press Enter on your keyboard. The function will be calculated, and the result will appear 
in the cell.
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To insert a function from the Function Library:
You can even use the Function Library on the Formulas tab to browse functions by category, 
such as Financial, Logical, Text, and Date & Time.

To access the Function Library, select the Formulas tab on the Ribbon. Look for the Function 
Library group.
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1. Select the desired function from the drop-down menu.

1
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2. The Function Arguments dialog box will appear. Select the Value1 field, then enter or 
select the desired cells.

3. When you're satisfied, click OK.

2
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4. The function will be calculated, and the result will appear in the cell.

4
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To use the insert Function command:
While the Function Library is a great place to browse for functions, sometimes you may prefer 
to search for one instead. You can do so using the Insert Function command.

1. Select the cell that will contain the function.

2. Click the Formulas tab on the Ribbon, then click the Insert Function command.
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3. The Insert Function dialog box will appear.
4. Select the function you want to perform or type a few keywords to search for a suitable 

function.
5. Review the results to find the desired function, then click OK.

3

4

5
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6. The Function Arguments dialog box will appear. From here, you’ll be able to enter or 
select the cells that will make up the arguments in the function.

7. When you’re satisfied, click OK.
8. The function will be calculated, and the result will appear in the cell.

6

7

8
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Note: You can copy the functions and apply to adjacent cells. Select the cell that contain 
the function, then click and drag the fill handle over the cells you want to fill.
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Audit Formulas (Trace precedent/dependent)
Formula auditing in Excel allows you to display the relationship between formulas and cells. 

Trade Precedents
After you calculated a value with formula, you can check which cells are used to calculate 
this value.

1. Select the cell that you want to audit.

1
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2. On the Formulas tab, in the Formula Auditing group, click Trace Precedents.

2

3. The arrows will showed to indicate which cells are used to calculate this value.

3
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Trace Dependents
To show arrows that indicate which cells depend on a selected cell.

1. Select the cell that you want to audit.

2

1

2. On the Formulas tab, in the Formula Auditing group, click Trace Dependents.
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Remove Arrows
To remove the arrows, click Remove Arrows on the Formulas tab.

3

3. Arrows show to indicate the cell (C13) depend on the selected cell (C12).
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Relative and Absolute Cell References

There are two types of cell references: relative and 
absolute.
Relative and absolute references behave differently when 
copied and filled to other cells.
Relative references change when a formula is copied to 
another cell.
Absolute references, on the other hand,  remain constant
no matter where they are copied.Students only



Relative references

• By default, all cell references are relative references. 
When copied across multiple cells, they change based on 
the relative position of rows and columns.
• For example, if you copy the formula =A1+B1 from row 1 to 

row 2, the formula will become =A2+B2. Relative 
references are especially convenient whenever you need 
to repeat the same calculation across multiple rows or 
columns. Students only



To create and copy a formula using relative references:

1. Select the cell that will contain the formula.

2. Enter the formula to calculate the desired value.

3. Press Enter on your keyboard. The formula will be calculated, and the result will be 
displayed in the cell.
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4. Locate the fill handle in the bottom-right corner of the desired cell.

5. Click and drag the fill handle over the cells you want to fill.
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6. Release the mouse. The formula will be copied to the selected cells with relative 
references, displaying the result in each cell.
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You can double-click the filled cells to check their formulas for accuracy. The relative cell 
references should be different for each cell, depending on their rows.
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Absolute references

• There may be a time when you don't want a cell 
reference to change when copied to other cells. Unlike 
relative references, absolute references do not change 
when copied or filled. You can use an absolute reference 
to keep a row and/or column constant.
• An absolute reference is designated in a formula by the 

addition of a dollar sign ($). It can precede the column 
reference, the row reference, or both.Students only



When writing a formula, you can press the F4 key on your 
keyboard to switch between relative and absolute cell 
references. This is an easy way to quickly insert an absolute 
reference.

You will generally use the $A$2 format when creating formulas that contain absolute 
references. The other two formats are used much less frequently.

$A$2 The column and the row do not change when copied

A$2 The row does not change when copied

$A2 The column does not change when copied
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To create and copy a formula using absolute references:

1. Select the cell that will contain the formula.

2. Enter the formula to calculate the desired value.

1
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3. Press Enter. The formula will calculate, and the result will display in the cell.

3. Click and drag the fill handle over the cells you want to fill. The formula will be copied to 
the selected cells with an absolute reference, and the values will be calculated in each 
cell.

3

4
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You can double-click the filled cells to check their formulas for accuracy. The absolute 
reference should be the same for each cell, while the other references are relative to the 
cell's row.

Be sure to include the dollar sign ($) whenever you're making an absolute reference across 
multiple cells.
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Define Name
You can name cells and cell ranges, and use those names in formulas. This is a useful feature 
that makes formulas easier to understand and maintain.

To name a cell:

1. Select a cell.

2. On the Formulas tab, in the Defined Names group, click Define Name.Students only



Define Name
3. Type a name for your selected cell, then select OK.

4. You will see the defined name appear in the Name box when you select the cell.Students only



Use Define Names in formulas
1. Select a cell and enter a formula.

2. Type the first letter of the name at where you want to use the name in that formula, and 
select the name from the list that appears.
Or, select Formulas > Use in Formula and select the name you want to use.
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Use Define Names in formulas
3. Press Enter. The result will appear in the cell.

Excel will automatically fill formulas for the column if you format your cells as table.Students only



Common Function
There are a variety of functions available in Excel. Here are some of the most common 
functions you'll use:

• SUM: This function adds all of the values of the cells in the argument.
• AVERAGE: This function determines the average of the values included in the argument. It 

calculates the sum of the cells and then divides that value by the number of cells in the 
argument.

• COUNT: This function counts the number of cells with numerical data in the argument. This 
function is useful for quickly counting items in a cell range.

• MAX: This function determines the highest cell value included in the argument.
• MIN: This function determines the lowest cell value included in the argument.
• COUNTIF: This function counts cells based on one criteria.
• SUMIF: This function sums cells based on one criteria.
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Example - COUNTIF Function
• The COUNTIF function counts the number of cells in a range, that meets a given criteria.
• COUNTIF can be used to count cells with dates, numbers, and text that match specific 

criteria. 
• The syntax for the COUNTIF function is:

• range: The range of cells that you want to count based on the criteria.
• criteria: the criteria used to determine which cells to count.

COUNTIF(range, criteria)
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Example - COUNTIF Function
• The COUNTIF function below counts the number of cells that contain the value 20.

• The COUNTIF function below counts the number of cells that contain the value 20.
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Example - COUNTIF Function
• The COUNTIF functions below count the number of cells that contain Google or Facebook.

The same method can be applied to SUMIF/AVERAGEIF function.
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AutoSum Command
The AutoSum command allows you to automatically insert the most common functions into 
your formula, including SUM, AVERAGE, COUNT NUMBERS, MIN, and MAX.

1. Select an empty cell.
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2. In the Editing group on the Home Tab, click the arrow next to the AutoSum command. 
Then, choose the desired function from the drop-down menu.

3. Excel will place the function in the cell and automatically select a cell range for the 
argument. You can manually enter the desired cells into the argument.
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4. Press Enter on your keyboard to get the result.

Note: The AutoSum command can also be accessed from the Formulas tab on the Ribbon.
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Days Formula

• To insert the current date or time so that it is updatable, 
use TODAY and NOW functions.

Formula Description (Result)

=TODAY() Current date (varies)

=NOW() Current date and time (varies)

The results of the TODAY and NOW functions change only when the worksheet is calculated 
or when a macro that contains the function is run. Cells that contain these functions are not 

updated continuously. The date and time that are used are taken from the computer's 
system clock.
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NETWORKDAYS Function
• The NETWORKDAYS function calculates the number of working days between two dates. 

NETWORKDAYS automatically excludes weekends (Saturday and Sunday) and can 
optionally exclude a list of holidays supplied as dates.

• Syntax:

• start_date - The start date.
• end_date - The end date.
• holidays - [optional] A list of one or more dates that should be considered non-work 

days.

=NETWORKDAYS (start_date, end_date, [holidays])
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To calculate the working days without include the holidays:

1. Select the cell.
2. Type =NETWORKDAYS and a left parenthesis (.
3. Select the cell for start_date.
4. Select the cell for end_date and type a right parenthesis ).
5. Press Enter. The result will appear.
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To calculate the working days including the holidays:

1. Select the cell.
2. Type =NETWORKDAYS and a left parenthesis (.
3. Select the cell for start_date.
4. Select the cell for end_date.
5. Select the cell(s) for holidays and type a right parenthesis ).
6. Press Enter. The result will appear.

Students only



Function Wizard
Create a formula in Excel by using the Function Wizard
If you do not feel very comfortable with Excel spreadsheet formulas yet, the Insert 
Function wizard will give you a helpful hand. Review the explanation for each function and 
apply the function which best suit your need.
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Lesson 6: Text Functions



Text Functions
• Excel has many functions to offer when it comes to manipulating text strings.

Left
To extract the leftmost characters from a string, use the LEFT function.

Right
To extract the rightmost characters from a string, use the RIGHT function.

=LEFT (text, [num_chars])

=RIGHT (text, [num_chars])

Students only



Text Functions
Lower Case
Use the LOWER function to convert all letters in a text string to lowercase.

Upper Case
Use the UPPER function to convert all letters in a text string to uppercase.

=LOWER (text)

=UPPER (text)Students only



Text Functions
Proper Case
Use the PROPER function to convert a text string to proper case. That is, the first letter in each 
word in uppercase, and all other letters in lowercase.

=PROPER (text)
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Concatenate Strings
• Use CONCATENATE, one of the text functions, to join two or more text strings into one string.

• Syntax:

CONCATENATE(text1, [text2], ...)

• In our example, we want to combine the text in cells A2 and B2, so we'll make each of 
those an argument:

=CONCATENATE(B2, A2)
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Concatenate Strings
• You may have noticed that the first and last names don't have a space in between them. 

That's because CONCATENATE will combine exactly what you tell it to combine, and 
nothing more. If you want punctuation, spaces, or any other details to appear in the cell, 
you’ll need to tell CONCATENATE to include it.

• To add a space, we can simply add another argument: " " (two double quotes around a 
space). Make sure the three arguments are separated by commas:

=CONCATENATE(B2," ",A2)
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Text to Columns

• To separate the contents of one Excel cell into separate 
columns, you can use the 'Convert Text to Columns 
Wizard'.
• For example, when you want to separate a list of full 

names into last and first names.
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1. Select the range with full names.

2. On the Data tab, in the Data Tools group, click Text to Columns.
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3. The following dialog box will appear. Choose Delimited and click Next.
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4. Clear all the check boxes under Delimiters except for the Comma and Space check box.
5. Click Finish.

This example has commas and spaces as 
delimiters. You may have other delimiters in 

your data. Experiment by checking and 
unchecking the different check boxes. You 
get a live preview of how your data will be 

separated.
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Result: Excel separated the names into two columns.
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Lesson 7: Print



Printing
1. Select the File tab. Backstage 

view will appear.
2. Select Print. The Print pane will appear.

Students only



Print Area
• Before you print an Excel workbook, it's important to decide exactly what information you 

want to print.
• For example, if you have multiple worksheets in your workbook, you will need to decide if 

you want to print the entire workbook or only active worksheets.
• There may also be times when you want to print only a selection of content from your 

workbook.
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To print active sheets:

Worksheets are considered active when selected.

1. Select the worksheet you want to print. To print multiple worksheets, click the first 
worksheet, hold the Ctrl key on your keyboard, then click any other worksheets you want 
to select.

2. Select the File tab. Backstage view will appear.
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3. Select Print. The Print pane will appear.
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4. Select Print Active Sheets from the Print Range drop-down menu.

5. Click the Print button.

Students only



To print the entire workbook:

1. Navigate to the Print pane.
2. Select Print Entire Workbook from the Print Range drop-down menu.

3. Click the Print button. Students only



To print a selection:

1. Select the cells you want to print. 2. Navigate to the Print pane.
3. Select Print Selection from the Print 

Range drop-down menu.
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1. A preview of your selection will appear in 
the Preview pane.

2. Click the Print button to print the 
selection.
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If you prefer, you can also set the print area in advance so you'll be able to visualize which 
cells will be printed as you work in Excel.
• Simply select the cells you want to print, click the Page Layout tab, select the Print 

Area command, then choose Set Print Area.

Keep in mind that if you ever need to print the entire workbook, you'll need to clear the 
print area. Students only



Repeat Titles on print
If your worksheet uses title headings, it's important to include these headings on each page 
of your printed worksheet. It would be difficult to read a printed workbook if the title headings 
appeared only on the first page. The Print Titles command allows you to select specific rows 
and columns to appear on each page.

1. Click the Page Layout tab on the Ribbon, then select the Print Titles command.
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2. The Page Setup dialog box will appear. From here, you can choose rows or columns to 
repeat on each page. 

3. Click the Collapse Dialog button next to the Rows to repeat at top: field.
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4. The cursor will become a small selection arrow, and the Page Setup dialog box will be 
collapsed. Select the row(s) you want to repeat at the top of each printed page.

5. Row 1 will be added to the Rows to repeat at top: field. Click the Collapse Dialog button 
again.
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6. The Page Setup dialog box will expand. To repeat a column as well, use the same process 
shown in steps 4 and 5.

7. When you're satisfied with your selections, click OK.
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Page layout / Page Break
1. Click the Page Break Preview

command to change to Page Break 
view.

2. Vertical and horizontal blue dotted 
lines denote the page breaks. Click 
and drag one of these lines to adjust 
that page break.
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Page layout / Page Break
3. In our example, all the pages now show the same number of rows due to the change in 

the page break.
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Lesson 8: Security



Allow people to edit selected cells only 
(Creating Forms)
• You can lock cells in Excel if you want to protect cells from being 

edited.
• By default, protecting a worksheet locks all cells so none of them 

are editable.
• To enable some cell editing, while leaving other cells locked, it's 

possible to unlock all the cells.
• You can lock only specific cells and ranges before you protect the 

worksheet and, optionally, enable specific users to edit only in 
specific ranges of a protected sheet.Students only



1. Select the cells or ranges you want to unlock by a password when the sheet is 
protected.

2. Go to the Review tab > Changes groups, and click Allow Users to Edit Ranges.

3. A dialog window will pop up, click New… button to add a new range.
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4. In the New Range dialog window, do the following:
• In the Title box, enter a meaningful range name instead of the 

default Range1 (optional).
• In the Refers to cells box, enter a cell or range reference. By default, the currently 

selected cell(s) or range(s) are included.
• In the Range password box, type a password. Or, you can leave this box empty to 

allow everyone to edit the range without password.
• Click the OK button.

5. Re-type the password and click OK.
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6. Click the Protect Sheet button at the button of the window to enforce the sheet 
protection.

7. Type the password to unprotect the sheet, select the check boxes next to the actions 
you want to allow, and click OK.

8. Re-type the password and click OK.

IMPORTANT: It’s recommended to save your password at somewhere, there’s no way to recover the 
password if forgotten.
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Protecting Worksheet
When you share an Excel file with other users, you may want to protect a worksheet to help 
prevent it from being changed.

1. Open your worksheet.
2. On the Review tab, in the Changes group, click Protect Sheet.

Students only



3. Enter a password.
4. Check the actions you allow the users of your worksheet to perform.
5. Click OK.

if you don't check any action, users can only view the Excel file.Students only



6. Re-type the password and click OK. Your worksheet is protected now.
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Protecting Workbook

If you protect the workbook structure, users cannot insert, 
delete, rename, move, copy, hide or unhide worksheets 
anymore.
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1. Open a workbook.
2. On the Review tab, in the Changes group, click Protect Workbook.

3. Check Structure, enter a password and click OK.

4. Reenter the password and click on OK.Students only



Workbook Encryption (Password to open)

Protect a workbook with a password to prevent others from 
adding, moving, deleting, hiding, or renaming the 
worksheets in the workbook.
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1. Click the File tab to access Backstage 
view.

2. From the Info pane, click the Protect 
Workbook command.

3. In the drop-down menu, choose Encrypt 
with Password.
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4. Enter a password and click OK.

5. Re-type the password and click OK.
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Data Validation
• You can use data validation to make sure that users enter certain values into a cell. In this 

example, we restrict users to enter age less than 18.
1. Select desired cell to restrict data.

2. On the Data tab, in the Data Tools group, click Data Validation.

1

2
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On the Settings tab:
1. In the Allow list, click Whole number.
2. In the Data list, click greater than or equal to.
3. Enter the Minimum values.

Data Validation

1

2

3
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Input Message
• Input messages appear when the user selects the cell and tell the user what to enter.

Data Validation

On the Input Message tab:
1. Check 'Show input message when cell is 
selected'.
2. Enter a title.
3. Enter an input message.

1

2
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Error Alert
• If users ignore the input message and enter a number that is not valid, you can show them 

an error alert.

Data Validation

On the Error Alert tab:
1. Check 'Show error alert after invalid data is 
entered'.
2. Enter a title.
3. Enter an error message.
4. Click OK.

1

2

3

4
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Data Validation Result
1. Select cell B4 and try to enter a number lower than 18.

Data Validation

2. An error message box will pop up.

1

2
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Remove Data Validation
1. On the Data tab, in the Data Tools group, click Data Validation.
2. Click Clear All.

Data Validation

1

2
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Lesson 9: Formulas in Depth



IF Function
• The IF function can check whether a condition is met, and return one value if TRUE, and 

another value is FALSE

• The syntax for the IF function is:

• logical_test : is any value or expression that can be evaluated to TRUE or FALSE

• value_if_true : is the value that is returned if logical_test is TRUE.

• value_if_false : is the value that is returned if logical_test is FALSE.

• For example, to “pass” scores above or equal to 50: =IF(A1>=50,“PASS”,“FAIL”)

IF(logical_test,value_if_true,value_if_false)
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To write an IF Function
1. Select a cell.

1

2

2. Type =IF and a left parenthesis (.

Notes:
You can see the syntax for the IF 
function
IF(logical_test,[value_if_true],[value_
if_false])
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To write an IF Function
3. Add the condition you want to test, and type a comma.

3

4

4. Add the value to return if the condition is true, and type a comma.

For this formula, we want to know if the 
value in cell B2 is greater than or equal 

to 50. We'll use some mathematical 
operators ( > for greater than and = for 

equals ) to write the condition.

Because this argument is text, we'll 
need to put it in double quotes (" ").
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To write an IF Function
5. Add the value to return if the condition is false, and type a right parenthesis ).

5

6. Press Enter. The result shows below.

6
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To write an IF Function
7. You can drag the fill handle down to add the formula to the other cells.

7
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IFS Function
• This function replaces the old method of nesting multiple IF functions and lets you enter up 

to 127 conditions making your formulas easy to read and understand.

• The syntax for the IFS function is:

• logical_test : is any value or expression that can be evaluated to TRUE or FALSE

• value_if_true : is the value that is returned if logical_test is TRUE.

=IFS(logical_test,value_if_true,...)
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IFS Function
1. Select a cell.

1

2

2. Type =IFS and a left parenthesis (.
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IFS Function
3. Add the logical_test1 you 

want to test, and type a 
comma.

4. Add the value to return if 
the logical_test1 is true, 
and type a comma.

5. Add the other logical and 
value to return if the logical 
is true, and type a right 
parenthesis ).

6. Press Enter

3

4
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Topic B: 3D Formulas

• A 3D formula is a formula that refers to the same cell or 
range of cells on multiple worksheets. 
• These are also known as cubed formulas or 3D reference. 
• Using 3D formulas allows you to calculate data throughout 

a workbook using multiple worksheets.
• It is important to realize that not all the functions will 

accept a 3D formula. Students only



List of Function
• The following functions can all be used in 3D formulas.
• AND , AVEDEV, AVERAGE, AVERAGEA, COUNT, 

COUNTA, DEVSQ, LARGE, MAX, MAXA, MEDIAN, MIN, 
MINA, OR, PERCENTILE, PRODUCT, QUARTILE, RANK, 
SKEW, SMALL, STDEV, STDEVA, STDEVP, STDEVPA, SUM, 
SUMSQ, TRIM, VAR, VARA, VARP, VARPA

https://bettersolutions.com/excel/formulas/three-dimensional.htm

For further reading about the function that can be used in 3d Formula please visit the link:Students only



Example using 3D Formulas
• Lets assume you have 4 worksheets in your workbook and 3 of them contain student grade 

for each subject Maths, Science and English. The first worksheet is intended to be a 
summary of these three classes.
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Example using 3D Formulas
To insert the 3D Formula:
We are going to insert a 3D formula for 
each of the items we want to count.
1. The first item in our Summary table 

is the total marks for Ariana 
Mansur

2. Select cell ”B2" and insert the SUM
function as normal.

1
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Example using 3D Formulas
3. Select the ”Math" worksheet tab with 

the mouse. Hold down the Shift key 
and select the ”English" worksheet 
tab with the mouse.

4. Select the cell you want to sum in this 
case cell ”B2” and type a right 
parenthesis ).

3
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Example using 3D Formulas
5. Press Enter

Once you press Enter on your keyboard. 
You will get the total marks for Ariana 
Mansur.

5
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CHOOSE Function
• Chooses a value or action to perform from a list of values, based on an index number.

• Syntax:

• Index_num: Specifies which value argument is selected. Index_num must be between 
1 and 254, or a formula or a reference to a number between 1 and 2

• Value1, : The first value from which to choose

• Value 2: [optional] The second value from which to choose

CHOOSE(index_num,value1,[value2],...)

Students only



How to use CHOOSE Function
1. Example of student data.
2. Select a cell.
3. Type =CHOOSE and a left 

parenthesis (.

Notes:
You can see the syntax for the CHOOSE 
function
CHOOSE(index_num,value1,[value2],…)

1

2

3
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How to use CHOOSE Function

4. Enter the index number, 
and the value1,…,value5

5. Type a right parenthesis ).
6. Press Enter

Notes:
Once you press enter, you will 
get the value of A2 which is 
Ariana Mansur.
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MATCH Function
• The MATCH function searches for a specified item in a range of cells, and then returns the 

relative position of that item in the range.

• Syntax:

• Lookup_value: is the value you use to find the value you want in the array, a number, 
text, or logical value, or a reference to one of these.

• Lookup_array: is a contiguous range of cells containing possible lookup values, an 
array of values, or a reference to an array.

• Match_type: is a number 1, 0, or -1 indicating which value to return.

MATCH(lookup_value,lookup_array,match_type)
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How to use MATCH Function

1. Select a cell.
2. Type =Match and a left 

parenthesis (.

Notes:
You can see the syntax for the 
MATCH function

MATCH(lookup_value,lookup_arra
y,match_type)

1

2
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How to use MATCH Function

3. Enter lookup_value, lookup 
array, match_type

Lookup_value = Anita
Lookup_array = A:A (All 
column)
Match_type=0 (exactly 
match)

Type a right parenthesis ). And 
then press Enter

4. You will get the result 6. That’s 
mean at the 6th row , you will 
find Anita.

3

4
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INDEX Function

• There are two ways to use the INDEX function:
• Array Form: If you want to return the value of a 

specified cell or array of cells
• Reference Form: If you want to return a reference to 

specified cells, 
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INDEX Function: Array Form
• Description: Returns the value of an element in a table or an array, selected by the row 

and column number indexes.
• Use the array form if the first argument to INDEX is an array constant.

• Syntax:

• array: is a range of cells or an array constant.
• row_num: selects the row in Array or Reference from which to return a value. If omitted, 

Column_num is required.
• column_num: selects the column in Array or Reference from which to return a value. If 

omitted, row_num is required.

INDEX(array, row_num, [column_num])
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Example using INDEX function for 
Array Form

1. Select a cell.

2. Type =INDEX and a left parenthesis 
(.

Notes:

You can see the syntax for the INDEX 
function for Array Form

INDEX(array, row_num, [column_num])

1
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Example using INDEX function for 
Array Form

3. Select column A until column 
E, and then type comma (,)

Notes:

You will get the array constant A:E

3
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Example using INDEX function for 
Array Form

4. Enter the row number 

5. Enter the column number

6. Type a right parenthesis ). And then press 
Enter

4

5

6

Row number

1Column number
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Example using INDEX function for 
Array Form

7. The index result for the name will be 
come out. Continue repeat the 
step for other index.

7

No. KP =INDEX(A:E,2,5)
Department =INDEX(A:E,2,2)
Hire Date =INDEX(A:E,2,3)
Salary =INDEX(A:E,2,4)

Row number

1 2 3 4 5Column number
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INDEX Function: Reference Form
• Description : returns the reference of the cell at the intersection of a particular row and 

column. If the reference is made up of nonadjacent selections, you can pick the selection 
to look in.

• Syntax:

• reference: is a reference to one or more cell ranges.

• row_num: selects the row in Array or Reference from which to return a value. If omitted, 
Column_num is required.

• column_num: selects the column in Array or Reference from which to return a value. If 
omitted, Row_num is required.

• area_num: selects a range in Reference from which to return a value. The first area 
selected or entered is area 1, the second area is area 2, and so on.

INDEX(reference, row_num, [column_num], [area_num])
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INDEX Function: Reference Form
1. Select a cell.

2. Type =INDEX and a left 
parenthesis (.

Notes:

You can see the syntax for the 
INDEX function for Reference Form

INDEX(reference, row_num, 
[column_num], [area_num])

1

2
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INDEX Function: Reference Form

3. Type left parenthesis (, enter the reference
(Area 1, Area 2, Area 3, Area 4), and then 
type right parenthesis )
• Area 1 : A2 : E6
• Area 2 : A7 : E12
• Area 3 : A13 : E18
• Area 4 : A19 : E25

Area 1

Area 2

Area 3

Area 4

3
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INDEX Function: Reference Form

4. Type Right parenthesis ). Enter the row 
number, comma(,), column number 
and then comma(,)

row_number = 1
column_num = 1

Row 1 for Area 1

Column 1 

Row 1 for Area 2

Row 1 for Area 3

Row 1 for Area 4

4
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INDEX Function: Reference Form

5. Enter the area number. Type Right 
parenthesis ). Then Press Enter

Notes: 

If you want to display the first data 
from Area 1, type 1

Row 1 for Area 1

Column 1 

Row 1 for Area 2

Row 1 for Area 3

Row 1 for Area 4
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INDEX Function: Reference Form
5. The index result for the name will be 

come out. Continue repeat the step 
for other index.Row 1 for Area 1

1 

Name:
=INDEX((A2:E6,A7:E12,A13:E18,A19:E25),1,1,1)

No. KP:
=INDEX((A2:E6,A7:E12,A13:E18,A19:E25),1,5,1)
Department:
=INDEX((A2:E6,A7:E12,A13:E18,A19:E25),1,2,1)

Hire Date:
=INDEX((A2:E6,A7:E12,A13:E18,A19:E25),1,3,1)

Salary:
=INDEX((A2:E6,A7:E12,A13:E18,A19:E25),1,4,1)

Column 2 3 4 5 

5

Students only



VLookup / H Lookup

• The VLOOKUP function performs a vertical lookup by 
searching for a value in the first column of a table and 
returning the value in the same row in 
the index_number position.
• The HLOOKUP function performs a horizontal lookup by 

searching for a value in the top row of the table and 
returning the value in the same column based on 
the index_number. Students only



VLookup
• Looks for a value in the leftmost column of a table, and then returns a value in the same row 

from a column you specify. By default, the table must be sorted in an ascending order.

• Syntax:

• lookup_value: is the value to be found in the first column of the table, and can be a value, 
a reference, or a text string.

• table_array: is a table of text, numbers, or logical values, in which data is retrieved. 
Table_array can be a reference to a range or a range name.

• col_index_num: is the column number in table_array from which the matching value 
should be returned. The first column of values in the table is column 1.

• range_lookup: is a logical value: to find the closest match in the first column (sorted in 
ascending order) = TRUE or omitted; find an exact match = FALSE.

VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)

Students only



To write a VLOOKUP function (Approximate Match)

1. Select a cell. Type =VLOOKUP and a left parenthesis (.
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To write a VLOOKUP function (Approximate Match)

2. Select the value to lookup.

• The first argument tells VLOOKUP what to search for. In this example, we want to lookup 
D2’s value (first argument) from the rightmost column of the yellow table (second 
argument). So our first argument is D2.
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To write a VLOOKUP function (Approximate Match)

3. Type a comma (,) and select the range or table to look for the value.

• The second argument is a cell range that tells VLOOKUP where to look for the value from 
our first argument. In our example, we want it to search for this value (D2) in cell 
range G1:H10, so our second argument is $G$1:$H$10.

You can use absolute references for second argument so this 
range won't change when we copy the formula to other cells.

To use Approximate Match, the cell range value MUST always 
start with value 0.
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To write a VLOOKUP function (Approximate Match)

4. Type a comma (,) and the number of the column where the lookup value is located.

• The third argument is the column index number. In our example, we're looking for the Bonus 
Rate. The rate are stored in the second column of the cell range from the previous 
argument, so our our third argument is 2.
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To write a VLOOKUP function (Approximate Match)

5. Type a comma (,) and then type TRUE to find the closest match.

• The fourth argument tells VLOOKUP if it should look for approximate or exact matches. 
TRUE=approximate matches; FALSE=exact matches. In this example, we don’t have an 
exact match in the cell range from previous argument, so our fourth argument is TRUE.
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To write a VLOOKUP function (Approximate Match)

6. Type Right parenthesis ). Then Press Enter. The result of VLOOKUP function will appear.

• It's important to know that VLOOKUP will always search the leftmost column in the cell 
range. Since our cell range is G1:H10, it will search the lookup_value (first argument) from 
column G (second argument) and return value from column H (third argument).
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To write a VLOOKUP function (Approximate Match)

7. You can drag the fill handle down to copy the formulas to the other rows.
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To write a VLOOKUP function (Exact Match)

For example, you have a list of data and you want to find the exact numerical score from 
the rate table for each student. You need to use Exact Match in your VLOOKUP function.

1. Select a cell. Type =VLOOKUP and a left parenthesis (.
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To write a VLOOKUP function (Exact Match)

2. Select the value to lookup.
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To write a VLOOKUP function (Exact Match)

3. Type a comma (,) and select the range or table to look for the value.

Use absolute references for second argument so this range won't change when we copy the 
formula to other cells.
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To write a VLOOKUP function (Exact Match)

4. Type a comma (,) and the number of the column where the lookup value is located.
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To write a VLOOKUP function (Exact Match)

5. Type a comma (,) and then type FALSE to find the exact match.

FALSE=exact match; TRUE=approximate match.
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To write a VLOOKUP function (Exact Match)

6. Type Right parenthesis ). Then Press Enter. The result of VLOOKUP function will appear.
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To write a VLOOKUP function (Exact Match)

7. You can drag the fill handle down to copy the formulas to the other rows.

As you can see, the result are come from the exact value from the cell range.
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HLOOKUP
• Looks for a value in the top row of a table or array of values and returns the value in the same 

column from a row you specify.

• The H in HLOOKUP stands for "Horizontal."
• Syntax

• lookup_value: is the value to be found in the first row of the table and can be a value, a 
reference, or a text string.

• table_array: is a table of text, numbers, or logical values in which data is looked up. 
Table_array can be a reference to a range or a range name.

• row_index_num: is the row number in table_array from which the matching value should 
be returned. The first row of values in the table is row 1.

• range_lookup: is a logical value: to find the closest match in the top row (sorted in 
ascending order) = TRUE or omitted; find an exact match = FALSE.

HLOOKUP(lookup_value,table_array,row_index_num,range_lookup)
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To write a HLOOKUP Function
1. Select a cell. Type =HLOOKUP and a left parenthesis (.

2. Select the value to lookup.
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To write a HLOOKUP Function
3. Type a comma (,) and select the range or table to look for the value.

4. Type a comma (,) and the number of the row where the lookup value is located.
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To write a HLOOKUP Function
5. Type a comma (,) and then type TRUE to find the closest match.

6. Type Right parenthesis ). Then Press Enter. The result of HLOOKUP functions will display.

Use Approximate Match or Exact Match depend on the situation.
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To write a HLOOKUP Function
7. You can drag the fill handle down to copy the formulas to the other rows.
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Lesson 10: PivotTables



PivotTable

• PivotTable allows you to summarize and analyze 
worksheet data by extracting pieces of data from a much 
larger data set. 
• A PivotTable does not change the original data set.
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To create a PivotTable
1. Select the table or cells (including column headers) you want to include in your 

PivotTable.
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To create a PivotTable
2. From the Insert tab, click the PivotTable command.
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To create a PivotTable
3. Excel will display the Create PivotTable dialog with your range or table name selected.

4. Select New Worksheet, or Existing Worksheet. For Existing Worksheet, select the cell where 
you want the PivotTable placed. In this example, we want to place the PivotTable on a 
new worksheet.

5. Click OK.
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To create a PivotTable
6. A blank PivotTable and Field List will appear on a new worksheet.
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To create a PivotTable
7. Once you create a PivotTable, you'll need to decide which fields to add. Each field is 

simply a column header from the source data. In the PivotTable Field List, check the box 
for each field you want to add. 
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To create a PivotTable
8. The selected fields will be added to one of the four areas below. Alternatively, you 

can drag and drop fields directly into the desired area.
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To create a PivotTable
9. The PivotTable will calculate and summarize the selected fields.
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To create a PivotTable
You can sort the data in a PivotTable using the Sort & Filter command on the Home tab. You 
can also apply any type of number formatting you want.

Be aware that some types of formatting may disappear when you modify the PivotTable.Students only



PivotTable Values
• Summarize by
By default, PivotTable fields that are placed in the Values area will be displayed as a SUM. If 
Excel interprets your data as text, it will be displayed as a COUNT. This is why it's so important 
to make sure you don't mix data types for value fields.

To change the default calculation:
1. Click on the arrow to the right of 

the field name, then select 
Value Field Settings option.

2. Change the desired calculation 
in the Summarize by section, 
then click OK.

1 2
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PivotTable Values
• Show data as
Instead of using a calculation to summarize the data, you can also display it as a 
percentage of a field.

1

To change the default calculation:
1. Click on the arrow to the right 

of the field name, then select 
Value Field Settings option. 

2. Select the Show data as option.
3. Choose your desired options.
4. Click OK.

2

3

4
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PivotTable Values
• Display a value as both a calculation and percentage

To change the default calculation:
1. Simply drag the item into the values section twice, right-click the value and select Field 

Settings, then set the Summarize by and Show data as options for each one.
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Update the Data Source of a PivotTable
If you change any of the data in your source worksheet, the PivotTable will not update 
automatically.

To manually update it, select the PivotTable and then on the Ribbon go to PivotTable
Analyze > click Refresh button. Or, you can just right-click anywhere in the PivotTable range, 
then select Refresh.
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Pivoting Data – To add columns
So far, our PivotTable has only shown one column of data at a time. In order to show multiple 
columns, you'll need to add a field to the Columns area.

1. Drag a field from the Field List into the Columns area.
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Pivoting Data – To add columns
2. The PivotTable will include multiple columns. In our example, there is now a column for 

each person's monthly sales, in addition to the grand total.
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Pivoting Data – To change a row or column

Changing a row or column can give you a completely different perspective on your data. All 
you have to do is remove the field in question, then replace it with another.

1. Drag the field you want to remove out of its current area. You can also uncheck the 
appropriate box in the Field List.
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Pivoting Data – To change a row or column

2. Drag a new field into the desired area.
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Pivoting Data – To change a row or column

3. The PivotTable will adjust—or pivot—to show the new data.
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PivotTable - Filters
Sometimes you may want focus on a certain section of your data. Filters can be used to 
narrow down the data in your PivotTable, so you can view only the information you need.

1. Drag a field from the Field List to the Filters area.
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PivotTable - Filters
2. The filter will appear above the PivotTable. Click the drop-down arrow, then check the 

box next to Select Multiple Items.
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PivotTable - Filters
3. Uncheck the box next to any item you don't want to include in the PivotTable, then 

click OK.
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PivotTable - Filters
4. The PivotTable will adjust to reflect the changes.
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PivotTable - Slicers
Slicers make filtering data in PivotTables even easier. Slicers are basically just filters but are 
easier and faster to use, allowing you to instantly pivot your data. If you frequently filter your 
PivotTables, you may want to consider using slicers instead of filters.

1. Select any cell in the PivotTable.
2. From the Analyze tab, click the Insert Slicer command.
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PivotTable - Slicers
3. A dialog box will appear. Check the box next to the desired field, then click OK.
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PivotTable - Slicers
4. The slicer will appear next to the PivotTable. Each selected item will be highlighted in blue. 
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PivotTable - Slicers
5. Just like filters, only selected items are used in the PivotTable. When you select or deselect

an item, the PivotTable will instantly reflect the change. Try selecting different items to see 
how they affect the PivotTable. Press and hold the Ctrl key on your keyboard to select 
multiple items at once.

You can also click the Filter icon in the 
top-right corner of the slicer to 

select all items at once.Students only



PivotCharts
• PivotCharts allow you to graphically represent your data 

which can help you to easily see comparisons, patterns 
and trends. 
• PivotCharts are like regular charts, except they display 

data from a PivotTable. Just like regular charts, you'll be 
able to select a chart type, layout, and style that will best 
represent the data.
• To create a PivotChart, you need to create a PivotTable 

first, and then insert a chart. Once that is done, the chart 
will behave like a PivotChart if you change the fields in the 
PivotTable Fields list.
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To create a PivotChart
1. Select any cell in your PivotTable.
2. From the Insert tab, click the PivotChart command.

3. Select the desired chart type and layout, then click OK.
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To create a PivotChart
4. The PivotChart will appear.
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To create a PivotChart
5. You can use filters or slicers to narrow down the data in your PivotChart. To view 

different subsets of information, change the columns or rows in your PivotTable.
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Lesson 11: Forecast Sheet



Forecast Sheet

• If you have historical time-based data, you can use it to 
create a forecast.
• When you create a forecast, Excel creates a new 

worksheet that contains both a table of the historical and 
predicted values and a chart that expresses this data.
• A forecast can help you predict things like future sales, 

inventory requirements, or consumer trends.
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Create a Forecast Sheet
1. In a worksheet, enter two data series that correspond to each other:

I. A series with date or time entries for the timeline
II. A series with corresponding values

• These values will be predicted for future dates.
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Create a Forecast Sheet
2. Select any cell in one of your series. Excel will automatically select the rest of the data for 

you in the next step.
3. Go to the Data tab and click Forecast Sheet.

2

3
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Create a Forecast Sheet
4. Pick either a line chart or a 

column chart for the visual 
representation of the forecast.

5. Pick an end date.
6. Click Create.

4

5

6
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Create a Forecast Sheet
7. Excel creates a new worksheet that contains both a table of the historical and predicted 

values and a chart that expresses this data.
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Lesson 12: Goal Seek



PMT Formula (Loan Calculator)
The PMT function returns a payment amount, so you can use 
it to:
• Calculate the monthly payment due on a personal loan
• Calculate the payment due for a Canadian mortgage loan, 

with interest compounded bi-annually
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PMT Formula (Loan Calculator)
The PMT function has the following syntax:

• rate : the interest rate for the loan.
• nper : the total number of payments for the loan.
• pv : the present value; also known as the principal.
• fv : optional. It is the future value, or the balance that you want to have left after the last 

payment. If fv is omitted, the fv is assumed to be zero.
• type is optional. If omitted, it is assumed to be zero, and payments are due at the end of 

the period. Use 1 in this argument if payments are due at the beginning of the period.

PMT(rate, nper, pv, [fv], [type])
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Example 1: Calculate Payment on Personal Loan

With the PMT function, you can return a 
payment amount, based on loan information. 
In this example:
• The loan amount is RM200,000.00
• The interest rate is 3.75% annually
• The loan is for a 30 year term, with 360 

monthly payments

In cell C6, the PMT function calculates the 
monthly payment, based on the annual rate, 
which is divided by 12 to get the monthly rate, 
the number of payments (periods) and the 
loan amount (present value):
=PMT(C2/12,C3,C4)
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Example 1: Calculate Payment on Personal Loan

• The payment, -230.29, is calculated as a negative amount, because you are paying that 
amount out of your bank account.

• If you would prefer to see the result as a positive number, you can use a minus sign before the 
PMT function: =-PMT(C2/12,C3,C4)

positive numberNegative number
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What is Goal Seek?
• Goal Seek is a built-in Excel tool that allows you to see how 

one data item in a formula impacts another.
• You might look at these as “cause and effect” scenarios.
• It’s useful to answer “what if” type questions because you 

can adjust one cell entry to see the result.
• Whenever you create a formula or function in Excel, you put 

various parts together to calculate a result. Goal Seek works 
in the opposite way: It lets you start with the desired result, 
and it calculates the input value that will give you that 
result.
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How to use Goal Seek
• From PMT load calculation, you already know you have to pay RM926.23 each month.
• Let’s assume a situation: What if you can pay only RM700 a month, how much worth of 

property you should buy?

If I can pay only RM 700 a month, how much worth of property I should buy?
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Use Goal Seek to determine the loan amount
1. Select the cell with the value you want to change.

2. From the Data tab, click the What-If Analysis command, then select Goal Seek from the 
drop-down menu.
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Use Goal Seek to determine the loan amount
A dialog box will appear with three fields:
3. The first field, Set cell:, will contain the desired result. In our example, cell C6 is already 

selected.
4. The second field, To value:, is the desired result. In our example, we'll enter 700 because 

we only can pay RM700 a month.
5. The third field, By changing cell:, is the cell where Goal Seek will place its answer. In our 

example, we'll select cell C4 because we want to determine the loan amount we can 
afford to borrow.

6. Click OK.
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Use Goal Seek to determine the loan amount
7. The dialog box will tell you if Goal Seek was able to find a solution. Click OK.

8. The result will appear in the specified cell. In our example, Goal Seek calculated that we 
can borrow RM151,150.17 loan amount if we only can pay RM700 a month.
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Lesson 13: Scenario Manager



Scenario Manager

• Scenarios let you substitute values for multiple cells (up to 
32) at the same time.
• You can create as many scenarios as you want and then 

compare them without changing the values manually. 
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Create various scenarios
For example, in the previous chapter, we used Goal Seek to determine the loan amount with 
a specific monthly payment. By using Scenario Manager, we can compare several sets of 
term to see how the monthly payment changes:

To define this set of values as a scenario, you first enter the values in a worksheet:

Changing cells

Result cell

The Changing 
cells have values that 
you type in, while 
the Result cell contains 
a formula that is based 
on the Changing cells 
(in this illustration cell 
C4 has the formula =-
PMT(C2/12,C3,C4)).
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Create various scenarios
1. From the Data tab, click the What-If Analysis command, then select Scenario 

Manager from the drop-down menu.
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Create various scenarios
2. A Scenario Manager dialog box will appear, click Add.
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Create various scenarios
3. Give the scenario a name.
4. Select the changing cell(s). Changing cells 

are the values that change between 
scenarios.

5. Write any comment (Optional).
6. Click OK.

If you select the Changing cells on your worksheet 
before adding a Scenario, the Scenario Manager 
will automatically insert the cells for you, otherwise 

you can type them by hand, or use the cell 
selection dialog to the right of the Changing cells 

dialog box.
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Create various scenarios
7. Enter the desired value for the changing cell(s), and click OK.

Although this example contains only one changing 
cell, a scenario can contain up to 32 cells.

8. Repeat steps 2 to 7 to create more scenarios.
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Using scenarios
Once you have created Scenarios, you can show each of the scenarios to see the changing 
values.
1. Select the scenario you want to show.
2. Click Show. The value will be changed based on the value you set for the scenario. 
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Using scenarios
You can generate a summary report to compare each of the scenarios side by side.
1. After adding all the scenarios you want to consider, click Summary.
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Using scenarios
2. In the resulting dialog, make sure the Result Cell control displays the cell that contains a 

formula that is based on the Changing cells, and click OK.
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Using scenarios
3. A Scenario Summary will be created in a new worksheet. Now you can compare your 

scenario to find a better solution.
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Lesson 14: Macro, Record and Play



Macro, Record and Play

• If you have tasks in Microsoft Excel that you do 
repeatedly, you can record a macro to automate those 
tasks.
• A macro is an action or a set of actions that you can run 

as many times as you want.
• When you create a macro, you are recording your mouse 

clicks and keystrokes. After you create a macro, you can 
edit it to make minor changes to the way it works.Students only



Show the developer tab
Show the developer tab
• Macros and VBA tools can be found on the Developer tab, which is hidden by default, so 

the first step is to enable it.

1. Click the File tab.
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Show the developer tab
2. Click Options.
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Show the developer tab
3. Under Customize the Ribbon and under Main Tabs, select the Developer check box, and 
click OK.
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Show the developer tab
4. You will now be able to see the Developer tab in the ribbon
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Record repeated tasks with Macro
In this example, we want record macro for formatting double accounting.

1. Select the cell that you want to record task with Macro.
2. On the Developer tab, click on the Record Macro.

1

2
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Record repeated tasks with Macro
You will get the following dialogue box:
3. Give the macro a name. The name should 

not contain any space or symbols.
4. Enter a shortcut key in the Shortcut key box.
5. Select where you want to store the macro.
6. Add description.
7. Click OK.

3

4

5

6

7

Do not use common shortcut key for your macro.
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Record repeated tasks with Macro
8. Excel is now recording the steps for your macro. There will be a stop button for you to stop 
recording at the left bottom of your worksheet.

9. Go to Home tab, click the arrow to open Format Cells window.

9

8
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Record repeated tasks with Macro
10. Choose Double Accounting from Underline drop down menu.
11. Click OK.

10

11
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Record repeated tasks with Macro
12. Now your cell is underlined as double accounting.

14. Now you can apply double accounting to any cells by simply pressing the new created 
Macro shortcut key.

If you use Macro to delete any data, you cannot use UNDO to recover the data. The data will 
be permanently deleted.

13. Click the stop button at the left bottom of your worksheet to stop recording.
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Record repeated tasks with Macro
To delete a macro:

1. On Developer tab, click Macros.

2. A dialog box will appear. Select the macro you want to delete and click delete.

2

1
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