Dapatkan berita terkini dari kami!

Langgan newsletter kami dan dapatkan pemberitahuan dan kekal update.

Berita terkini

Tutorial & Blog terkini

Kursus akan datang

Dirty COW Linux Vulnerability CVE-2016-5195

Pada 19 Oktober 2016, kelemahan keistimewaan peningkatan dalam Linux kernel telah didedahkan.  Kelemahan tersebut diberi nama Dirty COW kerana isu copy-on-write (COW). Dirty COW telah diwujudkan untuk masa yang lama – sekurang-kurangnya sejak 2007 dan kebanyakan servers berada di dalam risiko sekarang!

 

Mengeksploitasi pepijat ini bermaksud kebiasaan, pengguna yang tidak diberi keistimewaan pada server anda dapat memperoleh akses menulis ke mana-mana fail yang mereka boleh baca, dan oleh itu meningkatkan keistimewaan mereka pada sistem tersebut.

Kebanyakan versi Ubuntu dan Centos mengeluarkan patch untuk kelemahan ini. Walaubagaimanapun, kebanyakan konfigurasi OS tidak menerima kemaskini auto.  Oleh itu, anda perlu kemaskini OS anda secepat yang mungkin.

Di bawah adalah panduan yang diterbitkan oleh Hazel Virdó on DigitalOcean

Bagaimana untuk update Ubuntu/Centos

Untuk mengetahui samada server anda terjejas, periksa versi kernel anda.

uname -rv

Anda akan lihat output seperti ini:

4.4.0-42-generic #62-Ubuntu SMP Fri Oct 7 23:11:45 UTC 2016

Sekiranya versi anda lebih awal daripada di bawah, anda adalah terdedah:

  • 4.8.0-26.28 for Ubuntu 16.10
  • 4.4.0-45.66 for Ubuntu 16.04 LTS
  • 3.13.0-100.147 for Ubuntu 14.04 LTS
  • 3.2.0-113.155 for Ubuntu 12.04 LTS
  • 3.16.36-1+deb8u2 for Debian 8
  • 3.2.82-1 for Debian 7
  • 4.7.8-1 for Debian unstable

CentOS

Sesetengah versi CentOS boleh menggunakan this script provided by RedHat for RHEL untuk menguji kelemahan server anda.  Untuk mencuba, pertama muat turun skrip ini.

wget https://access.redhat.com/sites/default/files/rh-cve-2016-5195_1.sh

Kemudian run menggunakan bash.

bash rh-cve-2016-5195_1.sh

If you’re vulnerable, you’ll see output like this:

Your kernel is 3.10.0-327.36.1.el7.x86_64 which IS vulnerable. Red Hat recommends that you update your kernel. Alternatively, you can apply partial mitigation described at https://access.redhat.com/security/vulnerabilities/2706661 .

Membaiki isu tersebut di Ubuntu

Update dan upgrade package anda menggunakan apt-get.

sudo apt-get update && sudo apt-get dist-upgrade

Akhir sekali, anda perlu reboot server anda untuk terapkan perubahan.

sudo reboot

CentOS

Pada ketika ini, tiada pembaikan untuk CentOS 5 dan 6. Di dalam interim, anda boleh menggunakan this workaround daripada the Red Hat bug tracker.

Untuk update kernel anda pada CentOS 7, run:

sudo yum update

Kemudian, your server anda.

sudo reboot

Serverpilot

Sekiranya anda menggunakan Serverpilot, login ke SSH anda dan restart server anda dan patches secara automatic apply oleh team Serverpilot.

DigitalOcean

Sekiranya anda running pada Digitalocean dan droplet anda telah dicipta sebelum 19 Oktober 2016,anda perlu ikut arahan di atas dan update server anda secepat mungkin.

Shared Hosting

Sekiranya anda running website anda pada shared hosting, tulis ke syarikat hosting untuk pastikan sama ada telah update server.

Kongsi artikel ini:

Share on facebook
Facebook
Share on twitter
Twitter